summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-02-11 18:42:07 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-02-11 18:42:07 +0200
commit8490327e53efc0317cea5f68be2c8d91ebb82330 (patch)
tree95f9a301127fadd0c18160fb625680e255fc468b /gnu
parentfe554337de7fa739165958e655fa6fb9dc73cf06 (diff)
gnu: go-github-com-rakyll-statik: Fix building with go-1.18+.
* gnu/packages/golang.scm (go-github-com-rakyll-statik)[source]: Add snippet to allow building with a newer go.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 22f6ec5e8c..10b8eea84b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2070,7 +2070,14 @@ for speed on short messages.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0y0kbzma55vmyqhyrw9ssgvxn6nw7d0zg72a7nz8vp1zly4hs6va"))))
+ (base32 "0y0kbzma55vmyqhyrw9ssgvxn6nw7d0zg72a7nz8vp1zly4hs6va"))
+ (snippet
+ #~(begin
+ (use-modules (guix build utils))
+ ;; Fix compatibility with go-1.18+
+ (substitute* "statik.go"
+ (("fmt\\.Println\\(helpText\\)")
+ "fmt.Print(helpText + \"\\n\")"))))))
(build-system go-build-system)
(arguments
`(#:import-path "github.com/rakyll/statik"))