summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-08-03 08:18:14 +0000
committerLeo Famulari <leo@famulari.name>2016-08-22 15:46:41 -0400
commit85327d0d45703fb899e74088528388baee17e31c (patch)
tree05e095d079721529d34be75747ca4cd13a453fca /gnu
parentfe02c4c98aee859f7eb75e7ca18a78498ba7fa78 (diff)
gnu: Add libunique.
* gnu/packages/gnome.scm (libunique): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4ecb36be8a..8853df55ff 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5431,3 +5431,43 @@ GLib/GObject code.")
"Libgnomekbd is a keyboard configuration library for the GNOME desktop
environment, which can notably display keyboard layouts.")
(license license:lgpl2.0+)))
+
+;;; This package is no longer maintained:
+;;; https://wiki.gnome.org/Attic/LibUnique
+;;; "Unique is now in maintenance mode, and its usage is strongly discouraged.
+;;; Applications should use the GtkApplication class provided by GTK+ 3.0."
+(define-public libunique
+ (package
+ (name "libunique")
+ (version "3.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0f70lkw66v9cj72q0iw1s2546r6bwwcd8idcm3621fg2fgh2rw58"))))
+ (build-system glib-or-gtk-build-system)
+ (arguments
+ `(#:configure-flags '("--disable-static"
+ "--disable-dbus" ; use gdbus
+ "--enable-introspection")))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("gobject-introspection" ,gobject-introspection)
+ ("glib:bin" ,glib "bin")
+ ("gtk-doc" ,gtk-doc)))
+ (propagated-inputs
+ ;; Referred to in .h files and .pc.
+ `(("gtk+" ,gtk+)))
+ (home-page "https://wiki.gnome.org/Attic/LibUnique")
+ (synopsis "Library for writing single instance applications")
+ (description
+ "Libunique is a library for writing single instance applications. If you
+launch a single instance application twice, the second instance will either just
+quit or will send a message to the running instance. Libunique makes it easy to
+write this kind of application, by providing a base class, taking care of all
+the IPC machinery needed to send messages to a running instance, and also
+handling the startup notification side.")
+ (license license:lgpl2.1+)))