summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTim Howes <timhowes@lavabit.com>2020-10-15 19:52:04 -0700
committerLudovic Courtès <ludo@gnu.org>2020-11-02 14:59:35 +0100
commit89a4eb38c9b20b66856b53fe68e8ce8baf26ad0d (patch)
treedfa0b5637f6c12e8ccdb06eaa4b1c706c9e7543f /gnu
parentdcd8a50350aeca37a8b55b729a1951940f72d7d2 (diff)
gnu: emacs-julia-mode: Update to 0.4.
* gnu/packages/emacs-xyz.scm (emacs-julia-mode): Update to 0.4. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 19646cecf5..0107e60a62 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -83,6 +83,7 @@
;;; Copyright © 2020 Tomás Ortín Fernández <tomasortin@mailbox.org>
;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2020 Adam Kandur <rndd@tuta.io>
+;;; Copyright © 2020 Tim Howes <timhowes@lavabit.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -7884,23 +7885,19 @@ E-Prime forbids the use of the \"to be\" form to strengthen your writing.")
(license license:gpl3+))))
(define-public emacs-julia-mode
- ;; XXX: Upstream version remained stuck at 0.3. See
- ;; <https://github.com/JuliaEditorSupport/julia-emacs/issues/46>.
- (let ((commit "115d4dc8a07445301772da8376b232fa8c7168f4")
- (revision "1"))
(package
(name "emacs-julia-mode")
- (version (string-append "0.3-" revision "." (string-take commit 8)))
+ (version "0.4")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/JuliaEditorSupport/julia-emacs")
- (commit commit)))
+ (commit version)))
(file-name (git-file-name name version))
(sha256
(base32
- "1is4dcv6blslpzbjcg8l2jpxi8xj96q4cm0nxjxsyswpm8bw8ki0"))))
+ "1w131jb9mhvyjxa0p93iwfhzidgbcs6b8i6jg79yisqb9wchik99"))))
(build-system emacs-build-system)
(arguments
`(#:tests? #t
@@ -7911,7 +7908,7 @@ E-Prime forbids the use of the \"to be\" form to strengthen your writing.")
(synopsis "Major mode for Julia")
(description "This Emacs package provides a mode for the Julia
programming language.")
- (license license:expat))))
+ (license license:expat)))
(define-public emacs-smex
(package