summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-14 16:33:50 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:57:38 +0200
commit89ef08842607534292aadb7b7d77723acc69574e (patch)
tree967adeed8a7ed9199d7f0c6917ef45eb7d82d599 /gnu
parentef647e92014c46f5e9ca87ed38f14edfa5a7791d (diff)
gnu: rust-lexical-core-0.8: Update to 0.8.5.
* gnu/packages/crates-io.scm (rust-lexical-core-0.8): Update to 0.8.5. [arguments]: Don't skip the build. [cargo-development-inputs]: Add rust-approx-0.5. Change-Id: Ib9a467648ee9471679ce890d34fb243411049b44
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index e2fd3fc249..fe30acfb26 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -35479,23 +35479,23 @@ source audio format.")
(define-public rust-lexical-core-0.8
(package
(name "rust-lexical-core")
- (version "0.8.2")
+ (version "0.8.5")
(source
(origin
(method url-fetch)
(uri (crate-uri "lexical-core" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1152ll9xa7v4jz2mjvz0048gy32yg39mzgjaps89h0any7c2cfba"))))
+ (base32 "0ihf0x3vrk25fq3bv9q35m0xax0wmvwkh0j0pjm2yk4ddvh5vpic"))))
(build-system cargo-build-system)
(arguments
- `(#:skip-build? #t
- #:cargo-inputs
+ `(#:cargo-inputs
(("rust-lexical-parse-float" ,rust-lexical-parse-float-0.8)
("rust-lexical-parse-integer" ,rust-lexical-parse-integer-0.8)
("rust-lexical-util" ,rust-lexical-util-0.8)
("rust-lexical-write-float" ,rust-lexical-write-float-0.8)
- ("rust-lexical-write-integer" ,rust-lexical-write-integer-0.8))))
+ ("rust-lexical-write-integer" ,rust-lexical-write-integer-0.8))
+ #:cargo-development-inputs (("rust-approx" ,rust-approx-0.5))))
(home-page
"https://github.com/Alexhuszagh/rust-lexical/tree/master/lexical-core")
(synopsis "Lexical, to- and from-string conversion routines")