summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-02-10 19:41:54 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-02-10 19:41:54 +0100
commit8a0b625a2d0006621cc90ce85cd1396ac2919b79 (patch)
treef3085fdb1f2b750270f4dc0ec5ff6597cd4d2534 /gnu
parentfea66096a291f5eaf762da430e339feacac391b4 (diff)
gnu: scregseg: Update to 0.1.3.
* gnu/packages/bioinformatics.scm (scregseg): Update to 0.1.3. [source]: Simplify snippet. [build-system]: Use pyproject-build-system. [arguments]: Add phases 'set-numba-cache-dir and 'build-extensions; enable tests.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm24
1 files changed, 15 insertions, 9 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index ad8754f106..5717b4844e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -17787,7 +17787,7 @@ populations.")
(define-public scregseg
(package
(name "scregseg")
- (version "0.1.1")
+ (version "0.1.3")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -17796,16 +17796,22 @@ populations.")
(file-name (git-file-name name version))
(sha256
(base32
- "1k8hllr5if6k2mm2zj391fv40sfc008cjm04l9vgfsdppb80i112"))
+ "07g2barywa1wi8mggbxkbxqjw1fzd0a0l9cjdbkx4s40imb1dbxb"))
(snippet
- #~(begin
- (use-modules ((guix build utils)))
- (delete-file "src/scregseg/_utils.c")))))
- (build-system python-build-system)
+ '(delete-file "src/scregseg/_utils.c"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:tests? #false ; tests require network access
- #:phases
- (modify-phases %standard-phases
+ (list
+ #:phases
+ '(modify-phases %standard-phases
+ ;; Numba needs a writable dir to cache functions.
+ (add-before 'check 'set-numba-cache-dir
+ (lambda _
+ (setenv "NUMBA_CACHE_DIR" "/tmp")))
+ ;; Cython extensions have to be built before running the tests.
+ (add-before 'check 'build-extensions
+ (lambda _
+ (invoke "python" "setup.py" "build_ext" "--inplace")))
(add-after 'unpack 'do-not-fail-to-find-sklearn
(lambda _
;; XXX: I have no idea why it cannot seem to find sklearn.