summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-03-29 19:10:00 -0300
committerVinicius Monego <monego@posteo.net>2024-03-30 08:36:10 -0300
commit8a683b1628eeb3906922e4e7d14bbbc5e86481a1 (patch)
tree649afa1b549966ef05b25b4302e4155494aa65b8 /gnu
parent2e2d37855170ef65e63af43e0f279ccaa1b66960 (diff)
gnu: librecad: Update to 2.2.0.2.
* gnu/packages/engineering.scm (librecad): Update to 2.2.0.2. [arguments]<#:phases>: Delete the patch-boost-error, add-missing-headers and patch-paths phases. Remove trailing #t. * gnu/packages/patches/librecad-support-for-boost-1.76.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it. Change-Id: I23cc1a80b2e9e73bdef40575c4104480cc830d8c
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/engineering.scm34
-rw-r--r--gnu/packages/patches/librecad-support-for-boost-1.76.patch17
3 files changed, 3 insertions, 49 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 8ed40d3225..f2b480bded 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1617,7 +1617,6 @@ dist_patch_DATA = \
%D%/packages/patches/libphonenumber-reproducible-build.patch \
%D%/packages/patches/libqalculate-3.8.0-libcurl-ssl-fix.patch \
%D%/packages/patches/libquicktime-ffmpeg.patch \
- %D%/packages/patches/librecad-support-for-boost-1.76.patch \
%D%/packages/patches/libtar-CVE-2013-4420.patch \
%D%/packages/patches/libtgvoip-disable-sse2.patch \
%D%/packages/patches/libtgvoip-disable-webrtc.patch \
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 6af0c75eb2..01ded60c81 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -173,7 +173,7 @@
(define-public librecad
(package
(name "librecad")
- (version "2.2.0-rc2")
+ (version "2.2.0.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -182,39 +182,12 @@
(file-name (git-file-name name version))
(sha256
(base32
- "08cl4935c9vznz9qdw1zgd86rn7hl64zpfayxl07x21bhf53pn24"))
- (patches
- (search-patches "librecad-support-for-boost-1.76.patch"))))
+ "04pyywkc0nzhdx1wi0g63hldmbpdp0wvlrhqv8p3m1z6wyyafgjn"))))
(build-system qt-build-system)
(arguments
'(#:test-target "check"
#:phases
(modify-phases %standard-phases
- ;; Without this patch boost complains that "make_array" is not a
- ;; member of "boost::serialization".
- (add-after 'unpack 'patch-boost-error
- (lambda _
- (substitute* "librecad/src/lib/math/lc_quadratic.h"
- (("#include \"rs_vector.h\"" line)
- (string-append line
- "\n#include <boost/serialization/array_wrapper.hpp>")))
- (substitute* "librecad/src/lib/math/rs_math.cpp"
- (("#include <boost/numeric/ublas/matrix.hpp>" line)
- (string-append "#include <boost/serialization/array_wrapper.hpp>\n"
- line)))
- #t))
- ;; Fix build against Qt 5.11.
- (add-after 'unpack 'add-missing-headers
- (lambda _
- (substitute* "librecad/src/ui/generic/widgetcreator.cpp"
- (("#include <QPushButton>") "#include <QPushButton>
-#include <QActionGroup>"))
- #t))
- (add-after 'unpack 'patch-paths
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (substitute* "librecad/src/lib/engine/rs_system.cpp"
- (("/usr/share") (string-append out "/share"))))))
(replace 'configure
(lambda* (#:key inputs #:allow-other-keys)
(system* "qmake" (string-append "BOOST_DIR="
@@ -227,8 +200,7 @@
(mkdir-p bin)
(install-file "unix/librecad" bin)
(mkdir-p share)
- (copy-recursively "unix/resources" share))
- #t)))))
+ (copy-recursively "unix/resources" share)))))))
(inputs
(list boost muparser freetype qtbase-5 qtsvg-5))
(native-inputs
diff --git a/gnu/packages/patches/librecad-support-for-boost-1.76.patch b/gnu/packages/patches/librecad-support-for-boost-1.76.patch
deleted file mode 100644
index aa352e669f..0000000000
--- a/gnu/packages/patches/librecad-support-for-boost-1.76.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Upstream commit e02f3580311d50b617427652ff77988f6bd62d9d adding Boost 1.76
-compatibility.
-
-diff --git a/librecad/src/lib/engine/rs_ellipse.cpp b/librecad/src/lib/engine/rs_ellipse.cpp
-index 291f734ea..d47bf6ca4 100644
---- a/librecad/src/lib/engine/rs_ellipse.cpp
-+++ b/librecad/src/lib/engine/rs_ellipse.cpp
-@@ -48,6 +48,9 @@
- #include <boost/version.hpp>
- #include <boost/math/tools/roots.hpp>
- #include <boost/math/special_functions/ellint_2.hpp>
-+#if BOOST_VERSION > 104500
-+#include <boost/math/tools/tuple.hpp>
-+#endif
- #endif
-
- namespace{