summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-05-22 23:42:43 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-22 23:44:02 +0100
commit8c6fb6820390e67a8efa7e6caccb989275f0d7fb (patch)
tree48c3c8e5609d4ff55fb2bb22d9e338a30edacd87 /gnu
parentfb8ddfc57fe6c095da2ed4b7c8b65f2dd3d0fca9 (diff)
gnu: Add go-ginkgo.
* gnu/packages/golang-check.scm (go-ginkgo): New variable. Change-Id: I5c56c87a75c383ec159cee4e7eaa7808bfdcd1f7
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-check.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index b27e973e2e..3fc628a202 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -1198,6 +1198,21 @@ thoroughly
;;; Executables:
;;;
+(define-public go-ginkgo
+ (package
+ (inherit go-github-com-onsi-ginkgo-v2)
+ (name "ginkgo")
+ (arguments
+ (list
+ #:go go-1.20
+ #:import-path "github.com/onsi/ginkgo/ginkgo"
+ #:unpack-path "github.com/onsi/ginkgo"
+ #:install-source? #f))
+ (description
+ (string-append (package-description go-github-com-onsi-ginkgo-v2)
+ " This package provides an command line interface (CLI)
+tool."))))
+
(define-public go-keyify
(package
(inherit go-honnef-co-go-tools)