summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2023-02-16 16:46:45 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2023-02-17 09:00:48 +0100
commit8ecda39a3c1c40a4fb40ce2d4232af2683e9abf4 (patch)
tree38b46a954303fdecb4ecd06ef17556e561c6593a /gnu
parent23d56ba150ddeaa58e96b3ecf9df251fbd05ed00 (diff)
gnu: Add cl-nasdf.
* gnu/packages/lisp-xyz.scm (cl-nasdf, ecl-nasdf, sbcl-nasdf): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp-xyz.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index c45822fead..2faa0cab74 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -23832,6 +23832,52 @@ change since last write.
(cons (list "iolib" cl-iolib)
(package-inputs sbcl-nfiles)))))
+(define-public sbcl-nasdf
+ (let ((commit "c63a6ff12239f132844cc0703e79ea3b33dae630"))
+ (package
+ (name "sbcl-nasdf")
+ (version "0.1.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/atlas-engineer/ntemplate")
+ (commit commit)))
+ (file-name (git-file-name "cl-ntemplate" version))
+ (sha256
+ (base32
+ "1b57jkyrvr3n0c66lih4m34fqzw3s5yqlk91v7hg2gchcn3v9glg"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'cd-sdl
+ (lambda _
+ (chdir "nasdf")
+ #t)))))
+ (home-page "https://github.com/atlas-engineer/ntemplate")
+ (synopsis "ASDF helpers for system setup, testing and installation")
+ (description
+ "NASDF is an ASDF extension providing utilities to ease system setup, testing and installation.
+
+@itemize
+@item Simple way to fetch Git submodules and “do the right thing” for
+setup. This may effectively supersede Quicklisp. A benefit of using Git
+submodules over the default Quicklisp distribution is improved
+reproducibility.
+@item Test helpers, like distinction between offline and online tests, or
+continuous integration options, and warning reports.
+@item Installation helpers, for instance to install libraries, icons and
+desktop files to the right directories.
+@end itemize\n")
+ (license license:bsd-3))))
+
+(define-public ecl-nasdf
+ (sbcl-package->ecl-package sbcl-nasdf))
+
+(define-public cl-nasdf
+ (sbcl-package->cl-source-package sbcl-nasdf))
+
(define-public sbcl-nclasses
(package
(name "sbcl-nclasses")