summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNadya Voronova <voronovank@gmail.com>2018-03-28 03:42:15 +0300
committerLudovic Courtès <ludovic.courtes@inria.fr>2018-03-28 17:13:00 +0200
commit910deec66cac3f7f0cb881c6567f19bc92dbae64 (patch)
treea0d74d91474ed3c2da4f3dc0319690cb8d7a10b6 /gnu
parentc5e7bca248bf5f390265e481e194ff41a58fcc18 (diff)
gnu: Add tcalc.
* gnu/packages/maths.scm (tcalc): New variables. Signed-off-by: Ludovic Courtès <ludovic.courtes@inria.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 808e7d1b5f..eca45d05f5 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2017 Dave Love <me@fx@gnu.org>
;;; Copyright © 2018 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
+;;; Copyright © 2018 Nadya Voronova <voronovank@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3840,3 +3841,24 @@ routines designed for solving ODEs resulting from 1-D, 2-D and 3-D partial
differential equations (PDE) that have been converted to ODEs by numerical
differencing.")
(license license:gpl2+)))
+
+(define-public tcalc
+ (package
+ (name "tcalc")
+ (version "2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://sites.google.com/site/mohammedisam2000/tcalc/tcalc-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0jq806m4dqfia85nppfm75mml9w57g0cgv4cdw9bp3zymda83s0m"))))
+ (build-system gnu-build-system)
+ (synopsis "The terminal calculator")
+ (description
+ "The terminal calculator is a small program to help users of the GNU/Linux
+terminal do calculations simply and quickly. The formula to be calculated can
+be fed to @command{tcalc} through the command line.")
+ (home-page "https://sites.google.com/site/mohammedisam2000/tcalc")
+ (license license:gpl3+)))