summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBrian Leung <leungbk@mailfence.com>2019-10-14 14:07:48 -0700
committerBrian Leung <leungbk@mailfence.com>2019-10-14 14:08:41 -0700
commit914379a503e6e3124af7d80ce960641bf4862758 (patch)
tree060ee124c709afc06a4479cdbc2d190486978f36 /gnu
parent100f3ccb736cdc77728af1f739ea82cc9da4b30c (diff)
gnu: Add emacs-git-link.
* gnu/packages/emacs-xyz.scm (emacs-git-link): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9a80188699..2a0c4832ed 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2420,6 +2420,31 @@ display and behaviour is easily customisable.")
window.")
(license license:gpl3+))))
+(define-public emacs-git-link
+ (package
+ (name "emacs-git-link")
+ (version "0.7.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sshaw/git-link.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "04xa6lp8wkjb6zs096bf4sz124grcjj15xv1h009bmn2j95rggj6"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:tests? #t
+ #:test-command '("make" "test")))
+ (home-page "https://github.com/sshaw/git-link")
+ (synopsis "Create links for files and commits in GitHub/GitLab/etc. repos")
+ (description
+ "@code{git-link} returns the URL for the current buffer's file location
+at the current line number or active region. @code{git-link-commit} returns
+the URL for a commit. URLs are added to the kill ring.")
+ (license license:gpl3+)))
+
(define-public emacs-apheleia
(package
(name "emacs-apheleia")