summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-06-23 14:44:54 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-10-27 16:40:18 +0200
commit930b1e04585fe0ecd8c8792093ebc8ebb509ad4b (patch)
tree58064c9df29e45e63c2fd1c61f358c922f639814 /gnu
parentd9686315bd372034ddec95b0c9847dbb59911123 (diff)
gnu: Add r-awst.
* gnu/packages/bioconductor.scm (r-awst): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 65f4debbac..f048caa9fb 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2317,6 +2317,33 @@ reproducible gene expression signatures capable of accurately distinguishing
tumor samples from healthy controls.")
(license license:artistic2.0)))
+(define-public r-awst
+ (package
+ (name "r-awst")
+ (version "1.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "awst" version))
+ (sha256
+ (base32
+ "0iw3zycmj95rmdx7f2w0j4yxkzd90y87lrzgdn9cyvvzi5avflav"))))
+ (properties `((upstream-name . "awst")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-summarizedexperiment))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/drisso/awst")
+ (synopsis "Asymmetric within-sample transformation")
+ (description
+ "This package @dfn{awst} (Asymmetric Within-Sample Transformation) that
+regularizes RNA-seq read counts and reduces the effect of noise on the
+classification of samples. AWST comprises two main steps: standardization and
+smoothing. These steps transform gene expression data to reduce the noise of
+the lowly expressed features, which suffer from background effects and low
+signal-to-noise ratio, and the influence of the highly expressed features,
+which may be the result of amplification bias and other experimental
+artifacts.")
+ (license license:expat)))
+
(define-public r-baalchip
(package
(name "r-baalchip")