summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-09-07 23:32:22 +0100
committerChristopher Baines <mail@cbaines.net>2023-09-27 12:07:19 +0100
commit9bf19a302ba10d47eafed054a066fbe30a3f2ec0 (patch)
treea1484cc731febc4a4788f5eb6bd48e320610ba21 /gnu
parent56dae77d1c69649fbee0d865d81fcc83471d1fe2 (diff)
gnu: python-rad: Update to 0.17.1.
* gnu/packages/astronomy.scm (python-rad): Update to 0.17.1. [arguments]{tests?}: Disable them to break dependencies cycle. [native-inputs]: Remove python-astropy, python-pytest, python-pytest-doctestplus, python-pytest-openfiles. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm16
1 files changed, 7 insertions, 9 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 95c585079c..a402c63e9f 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -3807,22 +3807,20 @@ default) to world coordinates.")
(define-public python-rad
(package
(name "python-rad")
- (version "0.15.0")
+ (version "0.17.1")
(source (origin
(method url-fetch)
(uri (pypi-uri "rad" version))
(sha256
(base32
- "0j51pkywxdaqrfz162rdsywlvx1mbb2h0gi5framvhf25i1im7mb"))))
+ "11jhh3qmd00g8sn6hcfshbpb2qy1rfj0xkxn30pd63lqazg4ra3p"))))
(build-system pyproject-build-system)
(arguments
- (list #:test-flags #~(list "-k" "not remote_data")))
- (native-inputs (list python-astropy
- python-pytest
- python-pytest-doctestplus
- python-pytest-openfiles
- python-semantic-version
- python-setuptools-scm))
+ (list
+ ;; XXX: Tests introduce dependencies cycle, breaking it by disable them.
+ ;; python-rad -> python-roman-datamodels -> python-crds -> python-rad
+ #:tests? #f))
+ (native-inputs (list python-semantic-version python-setuptools-scm))
(propagated-inputs (list python-asdf python-asdf-astropy))
(home-page "https://github.com/spacetelescope/rad")
(synopsis "Roman Attribute Dictionary")