summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-13 00:01:00 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:37 +0100
commit9d08707665083f37dcc45b19549bce00c5459c18 (patch)
treefee9828819fb4653d373fa0e441c160a8e129d2d /gnu
parent7044882ce75222f98bc1933665127184ba6a5f50 (diff)
gnu: ghc-pandoc-types: Update to 1.17.3.1.
* gnu/packages/haskell.scm (ghc-pandoc-types): Update to 1.17.3.1. [arguments]: Allow using a newer QuickCheck. [inputs]: Add ghc-string-qq; remove ghc-deepseq-generics. [native-inputs]: Add ghc-quickcheck, ghc-test-framework, ghc-test-framework-hunit, ghc-test-framework-quickcheck2, and ghc-hunit.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index bd5480d8f3..3d8f1dc65f 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -4785,7 +4785,7 @@ and bytestrings.")
(define-public ghc-pandoc-types
(package
(name "ghc-pandoc-types")
- (version "1.16.1.1")
+ (version "1.17.3.1")
(source (origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/"
@@ -4793,12 +4793,20 @@ and bytestrings.")
version ".tar.gz"))
(sha256
(base32
- "094mzgdxva84kcpjf9m8b5n3chm1wm44bzflh5x6xhddz6pb7zpq"))))
+ "0dhp5bcjl6605n2chiab5rp51zir3671gxkmwy34znh0s3vp85jb"))))
(build-system haskell-build-system)
+ (arguments
+ `(#:configure-flags (list "--allow-newer=QuickCheck")))
(inputs
`(("ghc-syb" ,ghc-syb)
("ghc-aeson" ,ghc-aeson)
- ("ghc-deepseq-generics" ,ghc-deepseq-generics)))
+ ("ghc-string-qq" ,ghc-string-qq)))
+ (native-inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
+ ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)
+ ("ghc-hunit" ,ghc-hunit)))
(home-page "http://johnmacfarlane.net/pandoc")
(synopsis "Types for representing a structured document")
(description