summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOlivier Dion <olivier.dion@polymtl.ca>2023-05-01 20:56:18 -0400
committerLudovic Courtès <ludo@gnu.org>2023-05-02 11:54:00 +0200
commit9d8b0a7848b93a73872152aeff43d13216405fad (patch)
tree78c5c9897db9cf70e1350f7af1138975a030b1df /gnu
parenta46a6d8222d5ebf2e2195a66e7e35a5f698bcfb3 (diff)
gnu: babeltrace: Fix build failure.
* gnu/packages/instrumentation.scm (babeltrace) [native-inputs]: Add autoconf, automake, libtool. [arguments]: Invoke autoreconf before 'configure. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/instrumentation.scm33
1 files changed, 24 insertions, 9 deletions
diff --git a/gnu/packages/instrumentation.scm b/gnu/packages/instrumentation.scm
index c25086127a..114b100807 100644
--- a/gnu/packages/instrumentation.scm
+++ b/gnu/packages/instrumentation.scm
@@ -17,6 +17,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages instrumentation)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
#:use-module (gnu packages bison)
@@ -93,7 +94,8 @@
(add-before 'configure 'set-environment-variables
(lambda _
(setenv "BABELTRACE_DEV_MODE" "1")
- (setenv "BABELTRACE_MINIMAL_LOG_LEVEL" "TRACE"))))))
+ (setenv "BABELTRACE_MINIMAL_LOG_LEVEL" "TRACE")
+ (invoke "autoreconf" "-vfi"))))))
(inputs
(list glib))
;; NOTE - elfutils is used for the LTTng debug information filter
@@ -104,15 +106,28 @@
(list elfutils))
;; NOTE - python-3 is set here for generating the bindings. Users need to
;; install python-3 in their profile in order to use these bindings.
+ ;;
+ ;; NOTE - Babeltrace 2.0.4 is distributed with a aclocal.m4 that does not
+ ;; support Python3.10. We can either disable Python's bindings or we can
+ ;; reconfigure the project with our autoconf. This is because the
+ ;; distribution tarballs are generated on Ubuntu LTS 18.04.
+ ;;
+ ;; `paredit-raise-sexp' on the first list of native inputs and remove the
+ ;; 'autoreconf invokation whenever we bump to the next version that is
+ ;; goind to be generated on Ubuntu LTS 22.04.
(native-inputs
- (list asciidoc
- bison
- flex
- pkg-config
- python-3
- python-sphinx
- swig
- xmltoman))
+ (append
+ (list asciidoc
+ bison
+ flex
+ pkg-config
+ python-3
+ python-sphinx
+ swig
+ xmltoman)
+ (list autoconf
+ automake
+ libtool)))
(home-page "https://babeltrace.org/")
(synopsis "Trace manipulation toolkit")
(description "Babeltrace 2 is a framework for viewing, converting,