summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-10-16 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-10-23 02:00:06 +0200
commit9eea2db6aeb73a2f81d12a1334e200aa560ef5e2 (patch)
treec00ee600b179a22c9585382f4132bf11446ed738 /gnu
parent51aac125f0c17c6bdb1cb9c4534494a68714a5f8 (diff)
gnu: mpv: Use G-expressions.
* gnu/packages/video.scm (mpv)[arguments]: Rewrite as G-expressions.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm52
1 files changed, 27 insertions, 25 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index a9c1debc08..522894ec44 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2169,31 +2169,33 @@ SVCD, DVD, 3ivx, DivX 3/4/5, WMV and H.264 movies.")
(base32 "12qxwm1ww5vhjddl8yvj1xa0n1fi9z3lmzwhaiday2v59ca0qgsk"))))
(build-system waf-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "player/lua/ytdl_hook.lua"
- (("\"yt-dlp\",")
- (string-append
- "\"" (search-input-file inputs "bin/yt-dlp") "\",")))))
- (add-before 'configure 'build-reproducibly
- (lambda _
- ;; Somewhere in the build system library dependencies are enumerated
- ;; and passed as linker flags, but the order in which they are added
- ;; varies. See <https://github.com/mpv-player/mpv/issues/7855>.
- ;; Set PYTHONHASHSEED as a workaround for deterministic results.
- (setenv "PYTHONHASHSEED" "1")))
- (add-before 'configure 'set-up-waf
- (lambda* (#:key inputs #:allow-other-keys)
- (copy-file (search-input-file inputs "/bin/waf") "waf")
- (setenv "CC" "gcc"))))
- #:configure-flags (list "--enable-libmpv-shared"
- "--enable-cdda"
- "--enable-dvdnav"
- "--disable-build-date")
- ;; No check function defined.
- #:tests? #f))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-file-names
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "player/lua/ytdl_hook.lua"
+ (("\"yt-dlp\",")
+ (string-append
+ "\"" (search-input-file inputs "bin/yt-dlp") "\",")))))
+ (add-before 'configure 'build-reproducibly
+ (lambda _
+ ;; Somewhere in the build system library dependencies are enumerated
+ ;; and passed as linker flags, but the order in which they are added
+ ;; varies. See <https://github.com/mpv-player/mpv/issues/7855>.
+ ;; Set PYTHONHASHSEED as a workaround for deterministic results.
+ (setenv "PYTHONHASHSEED" "1")))
+ (add-before 'configure 'set-up-waf
+ (lambda* (#:key inputs #:allow-other-keys)
+ (copy-file (search-input-file inputs "bin/waf") "waf")
+ (setenv "CC" "gcc"))))
+ #:configure-flags
+ #~(list "--enable-libmpv-shared"
+ "--enable-cdda"
+ "--enable-dvdnav"
+ "--disable-build-date")
+ ;; No check function defined.
+ #:tests? #f))
(native-inputs
(list perl ; for zsh completion file
pkg-config python-docutils))