summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-16 23:23:41 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-02-25 14:46:54 -0500
commita02189e4cad445659f2256027d8c44207af45870 (patch)
treeea9de5eae3b24a9118d885104cfd7ed4ccd87de0 /gnu
parent542e9060fe85464579163839e0c24705d6eeef8d (diff)
gnu: gnome-boxes: Update to 43.3.
* gnu/packages/gnome.scm (gnome-boxes): Update to 43.3. [arguments]: Remove configure-flags. Adjust disable-gtk-update-icon-cache phase. [inputs]: Replace gtk+ with gtk, libsoup-minimal-2 with libsoup, webkitgtk-with-libsoup2 with webkitgtk. [native-inputs]: Replace vala with vala-next. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm20
1 files changed, 9 insertions, 11 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 9ffbce2df3..b44f47f861 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -12496,7 +12496,7 @@ integrate seamlessly with the GNOME desktop.")
(define-public gnome-boxes
(package
(name "gnome-boxes")
- (version "42.3")
+ (version "43.3")
(source
(origin
(method url-fetch)
@@ -12504,18 +12504,16 @@ integrate seamlessly with the GNOME desktop.")
(version-major version) "/"
"gnome-boxes-" version ".tar.xz"))
(sha256
- (base32 "1lv0bdh935qj6wkv3ixg2pcv8yrapj79z02gw4fal3rhz3xggvsn"))))
+ (base32 "14zd5ii3igy0am4zqw2jg1xshf2zxsy96yv5pss2vf6rh3svmnzf"))))
(build-system meson-build-system)
(arguments
(list #:glib-or-gtk? #t
- #:configure-flags #~(list "-Drdp=false"
- (string-append "-Dc_link_args=-Wl,-rpath="
- #$output
- "/lib/gnome-boxes"))
#:phases #~(modify-phases %standard-phases
(add-after 'unpack 'disable-gtk-update-icon-cache
(lambda _
- (setenv "DESTDIR" "/")))
+ (substitute* "meson.build"
+ (("gtk_update_icon_cache: true")
+ "gtk_update_icon_cache: false"))))
(add-before 'configure 'set-qemu-file-name
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "src/installed-media.vala"
@@ -12529,11 +12527,11 @@ integrate seamlessly with the GNOME desktop.")
itstool
pkg-config
python
- vala))
+ vala-next))
(inputs
(list glib-networking ;for TLS support
gsettings-desktop-schemas
- gtk+
+ gtk
gtk-vnc
gtksourceview
json-glib
@@ -12542,7 +12540,7 @@ integrate seamlessly with the GNOME desktop.")
libhandy
libosinfo
libsecret
- libsoup-minimal-2
+ libsoup
libusb
libvirt
libvirt-glib
@@ -12552,7 +12550,7 @@ integrate seamlessly with the GNOME desktop.")
spice-gtk
tracker
vte
- webkitgtk-with-libsoup2)) ;for webkit2gtk-4.0
+ webkitgtk))
(home-page "https://wiki.gnome.org/Apps/Boxes")
(synopsis "View, access, and manage remote and virtual systems")
(description "GNOME Boxes is a simple application to view, access, and