summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-03-27 12:29:07 -0300
committerVinicius Monego <monego@posteo.net>2024-03-30 09:23:24 -0300
commita17976e975001d3e95c998f1196a39bbb432de4f (patch)
treeecb9700556647d42387979341c911bc9c398f824 /gnu
parenta414fd2c9a48953692be402f65bfc084ee46ac67 (diff)
gnu: python-qasync: Update to 0.27.1.
* gnu/packages/python-xyz.scm (python-qasync): Update to 0.27.1. [build-system]: Use pyproject-build-system. [arguments]: Use G-Expressions. [native-inputs]: Remove python-pytest-runner. Add python-poetry-core. Change-Id: I3290a8b59f393c7bea6f200b5e538ad4be14d349
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6d15f4adae..cd10f304c8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19311,7 +19311,7 @@ applications.")
(define-public python-qasync
(package
(name "python-qasync")
- (version "0.22.0")
+ (version "0.27.1")
(source
(origin
;; There are no tests in the PyPI tarball.
@@ -19321,17 +19321,16 @@ applications.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1q9cllrwf94whr0f6mipa0hdq1rcyqvklwx19g35g2dav8f3xkjl"))))
- (build-system python-build-system)
+ (base32 "0j6ksfnq9qfjdfppbkdz7jh6w0gnslwnckhafmlgim29b25g0z51"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:test-target "pytest"
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'set-qpa
- (lambda _
- (setenv "QT_QPA_PLATFORM" "offscreen"))))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'set-qpa
+ (lambda _
+ (setenv "QT_QPA_PLATFORM" "offscreen"))))))
(native-inputs
- (list python-pytest python-pytest-runner))
+ (list python-poetry-core python-pytest))
(propagated-inputs
(list python-pyqt))
(home-page "https://github.com/CabbageDevelopment/qasync")