summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-12-12 17:03:05 +0100
committerMarius Bakke <marius@gnu.org>2022-12-12 20:23:31 +0100
commita2c6cc43548bd88871772cbc17bae55da9138cb2 (patch)
tree452b4302c0dd15064f6657b981ca1a48f011205c /gnu
parente1fc45b3eaaa2d09e3e202aff023b8aea6debbc9 (diff)
gnu: f2fs-tools: Update to 1.15.0.
* gnu/packages/linux.scm (f2fs-tools): Update to 1.15.0. (f2fs-tools/static)[arguments]: Add #:make-flags. Remove make-static phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm15
1 files changed, 3 insertions, 12 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index d483970dbb..4113e8e981 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5935,7 +5935,7 @@ obviously it can be shared with files outside our set).")
(define-public f2fs-tools
(package
(name "f2fs-tools")
- (version "1.14.0")
+ (version "1.15.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -5945,7 +5945,7 @@ obviously it can be shared with files outside our set).")
(file-name (git-file-name name version))
(sha256
(base32
- "06ss05n87i1c3149qb3n7j1qp2scv3g2adx0v6ljkl59ab9b5saj"))))
+ "1ffws8pbpzp9730v0wy5xjas698lnbd2p7wpr2gl4mx45rsay9a5"))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -6008,18 +6008,9 @@ disks and SD cards. This package provides the userland utilities.")
"-I" libuuid "/include/blkid")
(string-append "libblkid_LIBS=-L" libuuid-static "/lib -lblkid")))
#:disallowed-references (,util-linux)
+ #:make-flags '("LDFLAGS=-all-static")
#:phases
(modify-phases %standard-phases ; TODO: f2fs phases.
- (add-after 'unpack 'make-static
- (lambda _
- (define (append-to-file name body)
- (let ((file (open-file name "a")))
- (display body file)
- (close-port file)))
- (append-to-file "mkfs/Makefile.am" "\nmkfs_f2fs_LDFLAGS = -all-static\n")
- (append-to-file "fsck/Makefile.am" "\nfsck_f2fs_LDFLAGS = -all-static\n")
- (append-to-file "tools/Makefile.am" "\nf2fscrypt_LDFLAGS = -all-static -luuid\n")
- #t))
(add-after 'install 'remove-store-references
(lambda* (#:key outputs #:allow-other-keys)
;; Work around bug in our util-linux.