summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDaniel Ziltener <dziltener@lyrion.ch>2024-01-24 21:47:41 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-06 14:12:24 +0200
commita2d4a64d044f32b5c994806ae2b8b7ed745922aa (patch)
tree1197d1c95d71b759fcab9334589dbb8339e233e7 /gnu
parentfa6716e080c3485c5cb640efe5970f05b95a7255 (diff)
gnu: emacs-xyz: Add emacs-xref-union.
* gnu/packages/emacs-xyz.scm (emacs-xref-union): New variable. Change-Id: Idea12ce6869f5244a873e933cf1135db284d2391 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 890ed6297c..9186b5d432 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -38094,6 +38094,26 @@ work on alists, hash-table and arrays. All functions are prefixed with
commands, in particular @code{find-definition}.")
(license license:gpl3+)))
+(define-public emacs-xref-union
+ (package
+ (name "emacs-xref-union")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/xref-union-"
+ version ".tar"))
+ (sha256
+ (base32
+ "0ghhasqs0xq2i576fp97qx6x3h940kgyp76a49gj5cdmig8kyfi8"))))
+ (build-system emacs-build-system)
+ (home-page "https://elpa.gnu.org/packages/xref-union.html")
+ (synopsis "Combine multiple Xref backends")
+ (description
+ "This package provides a way to combine multiple Xref source
+(e.g., Etags and Eglot) and have the results all at once.")
+ (license license:gpl3+)))
+
(define-public emacs-burly
(package
(name "emacs-burly")