summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 14:56:42 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:24 +0200
commita37a87ddf19fa9651b2db601c9f8bd7270e25223 (patch)
tree8c06a30e1605f97a3d1019762f23b7a0ed459edb /gnu
parent9460219a1ae215506fc993d2313a315baeb9b789 (diff)
gnu: Add texlive-lualinalg.
* gnu/packages/tex.scm (texlive-lualinalg): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 576d2dc7b3..b3737b723b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16599,6 +16599,33 @@ others.")
fixing issues related to LuaTeX's hyphenation algorithm.")
(license license:lppl1.3c)))
+(define-public texlive-lualinalg
+ (package
+ (name "texlive-lualinalg")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/lualatex/lualinalg/"
+ "tex/lualatex/lualinalg/")
+ (base32
+ "0f29ymc5adcg8mh8lhgir6cj6f0kni0i53r6g35yqnd1jw9qr24q")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/lualinalg")
+ (synopsis "Linear algebra package for LaTeX")
+ (description
+ "The @code{lualinalg} package is developed to perform operations on
+vectors and matrices defined over the field of real or complex numbers inside
+LaTeX documents. It provides flexible ways for defining and displaying
+vectors and matrices. No particular environment of LaTeX is required to use
+commands in the package. The package is written in Lua, and @file{.tex} file
+is to be compiled with the LuaLaTeX engine. It may also save users efforts to
+copy vectors and matrices from other software (which may not be in
+LaTeX-compatible format) and to use them in a TeX file. The vectors and
+matrices of reasonable size can be handled with ease. The package can be
+modified or extended by writing custom Lua programs.")
+ (license license:lppl1.3c)))
+
(define-public texlive-babel-czech
(package
(name "texlive-babel-czech")