summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-03-25 02:04:52 +0100
committerLudovic Courtès <ludo@gnu.org>2021-03-29 16:47:18 +0200
commita5edd83ddb3aec9a896848b6a8b40e8aefbf2f68 (patch)
tree0d66aded7a284d74968e812b3c2aebf87731e809 /gnu
parent45debc7b855a97604d73da2dbf1b65bb5a080955 (diff)
gnu: Add julia-nanmath.
* gnu/packages/julia-xyz.scm (julia-nanmath): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/julia-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 5ba85f8bc0..6508fa52af 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -435,6 +435,26 @@ TLS} and cryptography C libary for Julia.")
wrappers.")
(license license:expat)))
+(define-public julia-nanmath
+ (package
+ (name "julia-nanmath")
+ (version "0.3.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mlubin/NaNMath.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1hczhz00qj99w63vp627kwk02l2sr2qmzc2rkwwkdwvzy670p25q"))))
+ (build-system julia-build-system)
+ (home-page "https://github.com/mlubin/NaNMath.jl")
+ (synopsis "Implementations of basic math functions")
+ (description "Implementations of basic math functions which return
+@code{NaN} instead of throwing a @code{DomainError}.")
+ (license license:expat)))
+
(define-public julia-orderedcollections
(package
(name "julia-orderedcollections")