summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-04-23 14:27:37 +0200
committerLeo Famulari <leo@famulari.name>2023-04-23 11:04:18 -0400
commitab5f309c43d4328ded6edb26f6a6082114e5726a (patch)
tree9e1244286b142be52b0b15a29d22814af888e036 /gnu
parent9d63c194c002ae7052f0521c7837ff5e15cff65a (diff)
gnu: Add go-github-com-dpotapov-go-spnego.
* gnu/packages/golang.scm (go-github-com-dpotapov-go-spnego): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1c4d0dd07e..a3d9ad7577 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1979,6 +1979,34 @@ standardized in RFC 7539.")
(description "Monolith-Go is a Go library for working with byte sequences.")
(license license:expat)))
+(define-public go-github-com-dpotapov-go-spnego
+ (let ((commit "298b63a544303a239753d04314aada5bdbad7e4a")
+ (revision "0"))
+ (package
+ (name "go-github-com-dpotapov-go-spnego")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/dpotapov/go-spnego")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0d3b0kazm0jskfml0pkhjn2v49m8dvqj4zymm49ldgvkhl9hcf6w"))))
+ (build-system go-build-system)
+ (arguments `(#:import-path "github.com/dpotapov/go-spnego"))
+ (propagated-inputs (list go-github-com-stretchr-testify
+ go-github-com-jcmturner-gokrb5-v8
+ go-golang-org-x-net))
+ (home-page "https://github.com/dpotapov/go-spnego")
+ (synopsis "Simple golang library for retry mechanism")
+ (description "This package is a simple Go library that provides retry
+functionality for functions that may fail. It includes various customizable
+retry strategies, such as fixed delay, backoff delay, and random delay.")
+ (license license:expat))))
+
(define-public go-github-com-deckarep-golang-set
(package
(name "go-github-com-deckarep-golang-set")