summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-12-19 14:58:52 -0500
committerMark H Weaver <mhw@netris.org>2014-12-19 22:47:28 -0500
commitab9d06be83a535f42b76861bd9914cd088c00907 (patch)
treef4d891b64a7248d41ac42eb0b3bce9c4ef4f86bf /gnu
parent66e0147e860300fce8b7396861df15304cdaa45b (diff)
gnu: Add libevdev.
* gnu/packages/xorg.scm (libevdev): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xorg.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 29af09ce38..b1d4fb529e 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2159,6 +2159,32 @@ synchronization between the X server and direct-rendering clients.")
(license license:x11)))
+(define-public libevdev
+ (package
+ (name "libevdev")
+ (version "1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.freedesktop.org/software/" name "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0iil4pnla0kjdx52ay7igq65sx32sjbzn1wx9q3v74m5g7712m16"))))
+ (build-system gnu-build-system)
+ (native-inputs `(("python" ,python)))
+ (home-page "http://www.freedesktop.org/wiki/Software/libevdev/")
+ (synopsis "Wrapper library for evdev devices")
+ (description
+ "libevdev is a wrapper library for evdev devices. it moves the common
+tasks when dealing with evdev devices into a library and provides a library
+interface to the callers, thus avoiding erroneous ioctls, etc.
+
+The eventual goal is that libevdev wraps all ioctls available to evdev
+devices, thus making direct access unnecessary.")
+ (license license:x11-style)))
+
+
(define-public xf86-input-evdev
(package
(name "xf86-input-evdev")