summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-02-25 01:03:52 +0100
committerLudovic Courtès <ludo@gnu.org>2018-02-25 01:03:52 +0100
commitad2e1422783000dd4224eab155ce532888aaef0b (patch)
tree04f606e862071325b170519d78cd4c23141c2365 /gnu
parentcff07bde98cdc78810c4c88b50c9165779b3d2cf (diff)
gnu: tar: Skip faulty test.
* gnu/packages/base.scm (tar)[arguments]: Add #:make-flags.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/base.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index 56b586c8eb..2a50080599 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -188,7 +188,13 @@ implementation offers several extensions over the standard utility.")
(substitute* "src/system.c"
(("/bin/sh")
(string-append bash "/bin/sh")))
- #t))))))
+ #t))))
+
+ ;; Test #92 "link mismatch" expects "a/z: Not linked to a/y" but gets
+ ;; "a/y: Not linked to a/z" and fails, presumably due to differences in
+ ;; the order in which 'diff' traverses directories. That leads to a
+ ;; test failure even though conceptually the test passes. Skip it.
+ #:make-flags '("TESTSUITEFLAGS=-k '!link mismatch'")))
;; When cross-compiling, the 'set-shell-file-name' phase needs to be able
;; to refer to the target Bash.