summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-05-02 21:08:39 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-05-06 23:16:48 +0300
commitad330f7d080828baec6a12c5b95466f4f3e2d9f8 (patch)
treeb798e4db6f966423528c690389d950ebfe551e17 /gnu
parentaf8ad9148fe8331c58de90c8f4ddefdaa1fb949e (diff)
gnu: rednotebook: Correctly wrap the binary.
* gnu/packages/rednotebook.scm (rednotebook)[arguments]: Adjust the 'wrap-with-library-paths phase to use the correct webkitgtk input. Remove trailing #t. Change-Id: I3d245f279ca704ab34023a8977a2c6f1003302ab
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/rednotebook.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/rednotebook.scm b/gnu/packages/rednotebook.scm
index a5dcc26efd..a67dee07bb 100644
--- a/gnu/packages/rednotebook.scm
+++ b/gnu/packages/rednotebook.scm
@@ -64,12 +64,11 @@
(let ((out (assoc-ref outputs "out"))
(gi-typelib-path (getenv "GI_TYPELIB_PATH"))
(webkitgtk-path (string-append
- (assoc-ref inputs "webkitgtk")
+ (assoc-ref inputs "webkitgtk-for-gtk3")
"/lib")))
(wrap-program (string-append out "/bin/rednotebook")
`("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
- `("LD_LIBRARY_PATH" ":" prefix (,webkitgtk-path)))
- #t))))))
+ `("LD_LIBRARY_PATH" ":" prefix (,webkitgtk-path)))))))))
(inputs
(list gtk+ gtksourceview-3 python-pyyaml python-pygobject
webkitgtk-for-gtk3))