summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-22 20:13:49 +0100
committerDavid Craven <david@craven.ch>2017-01-04 16:04:32 +0100
commitad3d730e3a6ef592f62578d1f40796272e2ea3ec (patch)
tree70b3116d78371d4eb0025ac0541b24209ececed4 /gnu
parent56f73eadc018bef27d895d6f3fd21d6b16a5ce50 (diff)
gnu: camlp4: Install camlp4 META file.
* gnu/packages/ocaml.scm (camlp4)[arguments]: Install in OCAMLPATH and META file. (ocaml-findlib)[arguments]: Delete camlp4 META file. Signed-off-by: David Craven <david@craven.ch>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm21
1 files changed, 18 insertions, 3 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index dd43741637..b3e3bc74ae 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -256,9 +256,19 @@ Git-friendly development workflow.")
;; This is a home-made 'configure' script.
(let ((out (assoc-ref outputs "out")))
(zero? (system* "./configure"
- (string-append "--libdir=" out "/lib")
+ (string-append "--libdir=" out
+ "/lib/ocaml/site-lib")
(string-append "--bindir=" out "/bin")
- (string-append "--pkgdir=" out)))))))))
+ (string-append "--pkgdir=" out
+ "/lib/ocaml/site-lib"))))))
+ (add-after 'install 'install-meta
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "camlp4/META.in"
+ (("directory = .*")
+ (string-append "directory = \"" out
+ "/lib/ocaml/site-lib/camlp4\"\n")))
+ (zero? (system* "make" "install-META"))))))))
(home-page "https://github.com/ocaml/camlp4")
(synopsis "Write parsers in OCaml")
(description
@@ -726,7 +736,12 @@ to the other.")
"-config" (string-append out "/etc/ocamfind.conf")
"-mandir" (string-append out "/share/man")
"-sitelib" (string-append out "/lib/ocaml/site-lib")
- "-with-toolbox")))))))
+ "-with-toolbox"))))
+ (add-after 'install 'remove-camlp4
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (delete-file-recursively
+ (string-append out "/lib/ocaml/site-lib/camlp4"))))))))
(home-page "http://projects.camlcity.org/projects/findlib.html")
(synopsis "Management tool for OCaml libraries")
(description