summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorhumanitiesNerd <catonano@gmail.com>2016-05-27 10:01:59 +0200
committerAlex Kost <alezost@gmail.com>2016-05-30 13:09:43 +0300
commitad6c4bc48a3fcb6195e4382df4036e2efae2b5c0 (patch)
tree97b0740c80e91055177a84f4d0363c7d6f18aa5a /gnu
parent4509ec72a4f7034e9a7087e802a84bbe04f4c12c (diff)
gnu: Add emacs-queue.
* gnu/packages/emacs.scm (emacs-queue): New variable. Signed-off-by: Alex Kost <alezost@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 7d0427d071..676e6232f4 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1707,3 +1707,25 @@ It is recommended to use @code{clojure-mode} with paredit or smartparens.")
The purpose of this library is to wrap all the quirks and hassle of
@code{package.el} into a sane API.")
(license license:gpl3+)))
+
+(define-public emacs-queue
+ (package
+ (name "emacs-queue")
+ (version "0.1.1")
+ (source (origin
+ (method uncompressed-file-fetch)
+ (uri (string-append "http://elpa.gnu.org/packages/queue-"
+ version ".el"))
+ (sha256
+ (base32
+ "0jw24fxqnf9qcaf2nh09cnds1kqfk7hal35dw83x1ari95say391"))))
+ (build-system emacs-build-system)
+ (home-page "http://www.dr-qubit.org/tags/computing-code-emacs.html")
+ (synopsis "Queue data structure for Emacs")
+ (description
+ "This Emacs library provides queue data structure. These queues can be
+used both as a first-in last-out (FILO) and as a first-in first-out (FIFO)
+stack, i.e. elements can be added to the front or back of the queue, and can
+be removed from the front. This type of data structure is sometimes called an
+\"output-restricted deque\".")
+ (license license:gpl3+)))