summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-12 23:59:04 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:37 +0100
commitaebb8db28929a74f67cf3f2dcf28469c8efe4b0e (patch)
tree751d7e1c40078b3c8ec37996413a7bf6af0513b1 /gnu
parenta7c0b95a5b13135c50f33ba778ab623f9354dbfb (diff)
gnu: ghc-mmorph: Update to 1.0.6.
* gnu/packages/haskell.scm (ghc-mmorph): Update to 1.0.6. [inputs]: Add ghc-mtl and ghc-transformers-compat.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index dfb74043e9..839ba1e8df 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -3626,7 +3626,7 @@ with various performance characteristics.")
(define-public ghc-mmorph
(package
(name "ghc-mmorph")
- (version "1.0.4")
+ (version "1.0.6")
(source
(origin
(method url-fetch)
@@ -3636,10 +3636,12 @@ with various performance characteristics.")
".tar.gz"))
(sha256
(base32
- "0k5zlzmnixfwcjrqvhgi3i6xg532b0gsjvc39v5jigw69idndqr2"))))
+ "1i8dzrc5qi3ryc9vrrmpn3sihmramsbhhd592w4w2k5g26qr3hql"))))
(build-system haskell-build-system)
- (home-page
- "https://hackage.haskell.org/package/mmorph")
+ (inputs
+ `(("ghc-mtl" ,ghc-mtl)
+ ("ghc-transformers-compat" ,ghc-transformers-compat)))
+ (home-page "https://hackage.haskell.org/package/mmorph")
(synopsis "Monad morphisms")
(description
"This library provides monad morphism utilities, most commonly used for