summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:25:28 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:49:33 +0200
commitaf5e66818f0ea1ddcc73404e3be60141e76466c0 (patch)
tree1c3095e2125bd97f8e91ec3cf9f04eff6dc9e5e7 /gnu
parent056b25dc89a984188c454d2e8bf8fb950542989f (diff)
gnu: Add texlive-wargame.
* gnu/packages/tex.scm (texlive-wargame): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c81c2f1681..7ef5b178e2 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -14723,6 +14723,32 @@ bundle, for which map files are available to provide a Vietnamese version.")
(license (list license:lppl1.3+
(license:fsf-free "file://source/generic/vntex/LICENSE-utopia.txt")))))
+(define-public texlive-wargame
+ (package
+ (name "texlive-wargame")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/wargame/" "source/latex/wargame/"
+ "tex/latex/wargame/")
+ (base32
+ "1j56fnq5m298ly650v0k7qla15kiwcwswsd7454wqv9f191gmhhh")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/wargame")
+ (synopsis "LaTeX package to prepare hex'n'counter wargames")
+ (description
+ "This package can help make classic Hex'n'Counter wargames using LaTeX.
+The package provide tools for generating Hex maps and boards Counters for
+units, markers, and so on Counter sheets Order of Battle charts Illustrations
+in the rules using the defined maps and counters The result will often be
+a PDF (or set of PDFs) that contain everything one will need for
+a game (rules, charts, boards, counter sheets). The package uses NATO App6
+symbology for units. The package uses NATO App6 symbology for units. The
+package uses TikZ for most things. The package support exporting the game to
+a VASSAL module.")
+ (license license:cc-by-sa4.0)))
+
(define-public texlive-witharrows
(package
(name "texlive-witharrows")