summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 17:21:15 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:11:29 +0200
commitb1dc3313f4b1ebeca909477452acb2f377ef9b05 (patch)
tree3b8a9a3b697223f92a45e23d0cb6afc039b6ac8a /gnu
parentaa5089ca880122375a6f3f5a2c5ef487f7f611b4 (diff)
gnu: Add texlive-yb-book.
* gnu/packages/tex.scm (texlive-yb-book): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 19795587f4..3ade2ffd57 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -32397,6 +32397,56 @@ provides three output modes: LaTeX, PostScript and PDF.")
dissertations at the Yazd University. The class requires use of XeLaTeX.")
(license license:lppl1.3c)))
+(define-public texlive-yb-book
+ (package
+ (name "texlive-yb-book")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/yb-book/" "source/latex/yb-book/"
+ "tex/latex/yb-book/")
+ (base32
+ "1brgy4y92888z7mc6yryasbv7xhcj560zsy5wz6ahcwny8f67mgg")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-anyfontsize
+ texlive-biblatex
+ texlive-bigfoot
+ texlive-changepage
+ texlive-chngcntr
+ texlive-csquotes
+ texlive-enumitem
+ texlive-fancyhdr
+ texlive-float
+ texlive-footmisc
+ texlive-geometry
+ texlive-ifmtarg
+ texlive-imakeidx
+ texlive-lastpage
+ texlive-libertine
+ texlive-mdframed
+ texlive-microtype
+ texlive-needspace
+ texlive-paralist
+ texlive-pgf
+ texlive-qrcode
+ texlive-setspace
+ texlive-soul
+ texlive-titlesec
+ texlive-ulem
+ texlive-wrapfig
+ texlive-xcolor
+ texlive-xifthen
+ texlive-xkeyval
+ texlive-zref))
+ (home-page "https://ctan.org/pkg/yb-book")
+ (synopsis "Template for YB branded books")
+ (description
+ "This template helps the author design books published on Amazon under
+the ``Y.B.'' brand.")
+ (license license:expat)))
+
(define-public texlive-yfonts
(package
(name "texlive-yfonts")