summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 14:26:43 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:12 +0200
commitb2525ab75ee7d90cada226d109fc992d77346513 (patch)
treec2f70d69bb012677a085262c9078c1b3d49e3740 /gnu
parentda0b9e4f92bf3734c137bcb915b64bc35b46d92a (diff)
gnu: Add texlive-checkcites.
* gnu/packages/tex.scm (texlive-checkcites): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f0a3951026..10bcc1ff3a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -8360,6 +8360,26 @@ drivers, and VTeX and pdfTeX.")
(define-deprecated-package texlive-latex-changebar texlive-changebar)
+(define-public texlive-checkcites
+ (package
+ (name "texlive-checkcites")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/support/checkcites/"
+ "scripts/checkcites/")
+ (base32
+ "0zfghyyq86xrbnb9bzl7z1p96s0n255b39v2srqslb2z37ppvjyz")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/checkcites")
+ (synopsis "Check citation commands in a document")
+ (description
+ "The package provides a Lua script written for the sole purpose of
+detecting undefined and unused references from LaTeX auxiliary or bibliography
+files.")
+ (license license:lppl1.3+)))
+
(define-public texlive-cmap
(package
(name "texlive-cmap")