summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-04-23 14:27:31 +0200
committerLeo Famulari <leo@famulari.name>2023-04-23 11:04:16 -0400
commitb334f914036fab2e0d9e7f3ee529abf0fcbdde89 (patch)
tree86b42d6d58766026e80c47205c70b058edb5d22d /gnu
parent9e903e9537e55c14799b84e0b81e92e32c8f70be (diff)
gnu: Add go-github-com-hashicorp-go-uuid.
* gnu/packages/golang.scm (go-github-com-hashicorp-go-uuid): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 52bb95a573..bccfee0b5d 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3840,6 +3840,31 @@ is similar to Go's standard library @code{json} and @code{xml} package.")
logging system.")
(license license:bsd-3))))
+(define-public go-github-com-hashicorp-go-uuid
+ (package
+ (name "go-github-com-hashicorp-go-uuid")
+ (version "1.0.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hashicorp/go-uuid")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0wd4maaq20alxwcvfhr52rzfnwwpmc2a698ihyr0vfns2sl7gkzk"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/hashicorp/go-uuid"))
+ (home-page "https://github.com/hashicorp/go-uuid")
+ (synopsis "Generate UUID-format strings")
+ (description
+ "This package generates UUID-format strings using high quality bytes.
+It is not intended to be RFC compliant, merely to use a well-understood string
+representation of a 128-bit value. It can also parse UUID-format strings into
+their component bytes.")
+ (license license:mpl2.0)))
+
(define-public go-github-com-hashicorp-go-version
(let ((commit
"03c5bf6be031b6dd45afec16b1cf94fc8938bc77")