summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-01-03 11:08:47 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-01-03 12:49:33 +0200
commitb40195e7f3f899ef1d7e8b8852a1540e49839cb5 (patch)
tree37a028141f13e1a7a671bf2872eec28bfcce2055 /gnu
parente43a91a4291b402a0cc87b23cf76cd1a201e4c0e (diff)
gnu: Add rust-funty-1.
* gnu/packages/crates-io.scm (rust-funty-1): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm27
1 files changed, 26 insertions, 1 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index ab90ec141b..e70ea9514f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Ivan Petkov <ivanppetkov@gmail.com>
-;;; Copyright © 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019, 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -9947,6 +9947,31 @@ pseudorandom number generator")
(description "Low-level Rust bindings for the Zircon kernel.")
(license license:bsd-3)))
+(define-public rust-funty-1
+ (package
+ (name "rust-funty")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "funty" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "19wx3p3jmv863y0mjb56sr4qf1kvqhl3fsyslkd92zli0p8lrlzy"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-development-inputs
+ (("rust-static-assertions" ,rust-static-assertions-1))))
+ (home-page "https://github.com/myrrlyn/funty")
+ (synopsis "Trait generalization over the primitive types")
+ (description
+ "Prior to 1.0, Rust had traits for the numeric primitive types to permit
+code to generalize over which specific type it accepted. This was never
+stabilized, and eventually removed. This library reïnstates these traits.")
+ (license license:expat)))
+
(define-public rust-futf-0.1
(package
(name "rust-futf")