summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-21 11:16:08 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-10 00:06:14 -0400
commitb78aab0739218bcd8cbb51ab3af9d6fda7ba19dc (patch)
treedaecb1a9e95c6b1b28cb50eee855ca7703a45b20 /gnu
parent75cb7e1866cfca307dfd84c2344516471a01169b (diff)
gnu: Add qmk-firmware-ergodox-ez-dvorak.
* gnu/packages/firmware.scm (qmk-firmware-ergodox-ez-dvorak): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/firmware.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 02fa5b1254..429e5aa1b2 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -1471,6 +1471,14 @@ normally. It defines 10 layers:
The complete keymap can be inspected at the ErgoDox EZ Configurator web site:
@url{https://configure.ergodox-ez.com/ergodox-ez/layouts/Wadz/latest/0}."))
+(define-public qmk-firmware-ergodox-ez-dvorak
+ (make-qmk-firmware
+ "ergodox_ez" "dvorak" #:description
+ "This is a rather plain Dvorak layout for the ErgoDox EZ, containing
+function and symbols on layer 1 and media and and mouse keys on layer 2. See
+the @file{layouts/community/ergodox/dvorak/keymap.c} source file for the
+keymap definition."))
+
(define-public qmk-udev-rules
(package
(inherit qmk-firmware-ergodox-ez-default)