summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-09-25 10:13:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-09-25 11:46:08 +0200
commitbbc69023d86f5bd4ffec994453e5bdfbf5c429f4 (patch)
treef085c5f6e91a580ae07def49bf8a88929707199d /gnu
parent79374801d08c8b3e0df264340fd7212a3dac10ab (diff)
gnu: Add python-semantic-version.
* gnu/packages/python.scm (python-semantic-version) (python2-semantic-version): New public variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ea641b8213..86ce70254d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -907,6 +907,34 @@ API for locking files.")
(define-public python2-lockfile
(package-with-python2 python-lockfile))
+(define-public python-semantic-version
+ (package
+ (name "python-semantic-version")
+ (version "2.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "semantic_version" version))
+ (sha256
+ (base32
+ "1h2l9xyg1zzsda6kjcmfcgycbvrafwci283vcr1v5sbk01l2hhra"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ; PyPI tarball lacks tests
+ (home-page "https://github.com/rbarrois/python-semanticversion")
+ (synopsis "Semantic versioning module for Python")
+ (description
+ "The @code{semantic_version} class is a small library for handling
+@uref{https://semver.org/, semantic versioning} (@dfn{SemVer}) in Python.
+
+It can compare versions, generate a new version that represents a bump in one of
+the version levels, and check whether any given string is a proper semantic
+version identifier.")
+ (license license:bsd-3)))
+
+(define-public python2-semantic-version
+ (package-with-python2 python-semantic-version))
+
(define-public python-setuptools
(package
(name "python-setuptools")