summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-12-16 00:28:51 +0100
committerMarius Bakke <marius@gnu.org>2020-12-17 00:15:49 +0100
commitbca05d07099703f37eaf3a0eab9b87ea3e472279 (patch)
treee8d2b6c533529bb515d0c24a04a751833c868018 /gnu
parent420ddd0a91d50b3d37003638af8dc19bbef02c01 (diff)
gnu: tcsh: Update to 6.22.03.
* gnu/packages/patches/tcsh-fix-autotest.patch: Remove test hunk that no longer applies. * gnu/packages/shells.scm (tcsh): Update to 6.22.03. [arguments]: Patch /usr/bin/env invocation. Adjust the test mention above with a substitution instead.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/patches/tcsh-fix-autotest.patch11
-rw-r--r--gnu/packages/shells.scm15
2 files changed, 13 insertions, 13 deletions
diff --git a/gnu/packages/patches/tcsh-fix-autotest.patch b/gnu/packages/patches/tcsh-fix-autotest.patch
index 200867cb9b..9f5790641b 100644
--- a/gnu/packages/patches/tcsh-fix-autotest.patch
+++ b/gnu/packages/patches/tcsh-fix-autotest.patch
@@ -63,17 +63,6 @@
AT_DATA([comment2.csh],
[[echo testing...@%:@\
---- tests/subst.at
-+++ tests/subst.at
-@@ -54,7 +54,7 @@ AT_CHECK([export HOME=$(getent passwd $(id -un) | awk -F: '{ print $(NF - 1) }')
- , [1
- ])
-
--AT_CHECK([export HOME=$(getent passwd $(id -un) | awk -F: '{ print $(NF - 1) }'); echo "echo ~$(id -un)/foo; echo \"\$HOME/foo\"" | tcsh -f | uniq dnl
-+AT_CHECK([export HOME=$(getent passwd $(id -un) | awk -F: '{ print $(NF - 1) }'); echo "echo ~$(id -un)//foo; echo \"\$HOME/foo\"" | tcsh -f | uniq dnl
- | wc -l | tr -d ' \t'], , [1
- ])
-
--- tests/variables.at
+++ tests/variables.at
@@ -666,7 +666,8 @@ set listflags=(-xA $cwd/args.sh)
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 5b3ae21e0d..7d3dcbf3f0 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -372,7 +373,7 @@ written by Paul Haahr and Byron Rakitzis.")
(define-public tcsh
(package
(name "tcsh")
- (version "6.22.02")
+ (version "6.22.03")
(source (origin
(method url-fetch)
;; Old tarballs are moved to old/.
@@ -382,7 +383,7 @@ written by Paul Haahr and Byron Rakitzis.")
"old/tcsh-" version ".tar.gz")))
(sha256
(base32
- "0nw8prz1n0lmr82wnpyhrzmki630afn7p9cfgr3vl00vr9c72a7d"))
+ "1dv24bsp6faayinvwds092ylk9sb6894rl9ddm87y31a7mjzsb5y"))
(patches (search-patches "tcsh-fix-autotest.patch"))
(patch-flags '("-p0"))))
(build-system gnu-build-system)
@@ -407,6 +408,16 @@ written by Paul Haahr and Byron Rakitzis.")
;; Take care of pwd
(substitute* '("tests/commands.at" "tests/variables.at")
(("/bin/pwd") (which "pwd")))
+ (substitute* "Makefile"
+ ;; Likewise for /usr/bin/env.
+ (("/usr/bin/env") "env")
+ ;; Don't reset the environment (PATH, etc).
+ (("\\$\\(ENVCMD\\) -") "$(ENVCMD)"))
+ ;; This test does not expect the home directory from
+ ;; /etc/passwd to be '/'.
+ (substitute* "tests/subst.at"
+ (("\\$\\(id -un\\)/foo")
+ "$(id -un)//foo"))
;; The .at files create shell scripts without shebangs. Erk.
(substitute* "tests/commands.at"
(("./output.sh") "/bin/sh output.sh"))