summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSpencer King <spencer@nursiapress.com>2023-12-03 21:03:11 -0600
committerLudovic Courtès <ludo@gnu.org>2023-12-23 11:17:50 +0100
commitbdec4d867acd98551c22db58ae7c4ea313806243 (patch)
tree289e0e54c0e49ad93397c9c5b807a58720d0cb63 /gnu
parente008a1baca7f8c71d63367a4e9e192d3be5dc786 (diff)
gnu: Add python-icegrams.
* gnu/packages/python-xyz.scm (python-icegrams): New variable. Change-Id: Ia0044304f8b2002a5362813448a6172c2f3eef5b Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 79c739ad31..cab44be011 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -34374,6 +34374,29 @@ The database contains over 6.5 million entries, over 3.1 million unique word
forms, and about 300,000 distinct lemmas.")
(license license:expat)))
+(define-public python-icegrams
+ (package
+ (name "python-icegrams")
+ (version "1.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "icegrams" version))
+ (sha256
+ (base32 "1ajcjngvr4rlgb0q6p6vjz2sncwhvq3msjy6qaiz5g37vgvw2ij8"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-cffi))
+ (home-page "https://github.com/mideind/Icegrams")
+ (synopsis "Trigram statistics for Icelandic")
+ (description
+ "Icegrams is a Python package that encapsulates a large trigram
+library for Icelandic. You can use Icegrams to obtain probabilities (relative
+frequencies) of over a million different unigrams (single words or tokens), or of
+bigrams (pairs of two words or tokens), or of trigrams. Icegrams is useful for
+instance in spelling correction, predictive typing, to help disabled people
+write text fast, and for various text generation, statistics, and modeling tasks.")
+ (license license:expat)))
+
(define-public python-zeroc-ice-3.6
(package
(inherit python-zeroc-ice)