summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-26 14:52:37 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:16:20 +0200
commitbe5e260da1796935785cd48cbca2e312fc6053cf (patch)
treeadd553d85e672acb44de323ad5e7947504517242 /gnu
parentef93bf62ad7d0b06bd62affdb13c02a25714dea5 (diff)
gnu: Add texlive-luacomplex.
* gnu/packages/tex.scm (texlive-luacomplex): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 982cdb0fe6..9461cc1d63 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16381,6 +16381,29 @@ screen readers by adding alt-text indicating redacted content.")
attributes.")
(license license:lppl1.3+)))
+(define-public texlive-luacomplex
+ (package
+ (name "texlive-luacomplex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/lualatex/luacomplex/"
+ "tex/lualatex/luacomplex/")
+ (base32
+ "0fb75jzvl0gqqyfl6vrfwdpsxjfq7dyhmfbfibg9w6rqxzcd013p")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/luacomplex")
+ (synopsis "Operations on complex numbers inside LaTeX documents using Lua")
+ (description
+ "The @code{luacomplex} package is developed to define complex numbers and
+perform basic arithmetic on complex numbers in LaTeX. It also loads the
+@code{luamathspackage}. It provides an easy way to define complex numbers and
+perform operations on complex numbers. There is no particular environment for
+performing operations on complex numbers. The package commands can be used in
+any environment (including the mathematics environment).")
+ (license license:lppl1.3c)))
+
(define-public texlive-babel-czech
(package
(name "texlive-babel-czech")