summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-22 17:39:01 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-23 16:56:24 -0400
commitc1a4ef98932799adbd278068fa4fdd8c24fff714 (patch)
treee0b26e43b4ce57155659e004175793cf93f90f8d /gnu
parent47316120b73dd0a00b3b7fc38a2e7caaf5e30816 (diff)
gnu: libsecret: Update to 0.20.5, use gexps and remove input labels.
* gnu/packages/gnome.scm (libsecret): Update to 0.20.5. [outputs]: Delete doc output. [configure-flags]: Use gexps. Remove --with-html-dir and add -Dgtk_doc. [phases]{disable-problematic-tests}: New phase. {check}: Override and move after the install phase. [inputs]: Move docbook-xsl and libxml2 to... [native-inputs]: ... here. Remove input labels. Add dbus, docbook-xml-4.2, python, python-dbus and python-pygobject.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm59
1 files changed, 40 insertions, 19 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ae46e55c51..da123eefe8 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4997,7 +4997,7 @@ and the GLib main loop, to integrate well with GNOME applications.")
(define-public libsecret
(package
(name "libsecret")
- (version "0.20.4")
+ (version "0.20.5")
(source (origin
(method url-fetch)
(uri (string-append
@@ -5006,28 +5006,49 @@ and the GLib main loop, to integrate well with GNOME applications.")
"libsecret-" version ".tar.xz"))
(sha256
(base32
- "0a4xnfmraxchd9cq5ai66j12jv2vrgjmaaxz25kl031jvda4qnij"))))
- (build-system gnu-build-system)
- (outputs '("out" "doc"))
+ "0k9bs47rzb3dwvznb4179d6nw7rbzjdyd4y8hx6vazfd1wscxcrz"))))
+ (build-system meson-build-system)
(arguments
- `(#:tests? #f ; FIXME: Testing hangs.
- #:configure-flags
- (list (string-append "--with-html-dir="
- (assoc-ref %outputs "doc")
- "/share/gtk-doc/html"))))
+ (list
+ #:configure-flags
+ #~(list "-Dgtk_doc=false") ;requires gi-docgen
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-problematic-tests
+ (lambda _
+ (substitute* "libsecret/meson.build"
+ ;; The test-collection test fails non-deterministically (see:
+ ;; https://gitlab.gnome.org/GNOME/libsecret/-/issues/80).
+ ((".*'test-collection',.*") ""))))
+ (delete 'check)
+ (add-after 'install 'check
+ (lambda* (#:key tests? test-options #:allow-other-keys)
+ (when tests?
+ (setenv "HOME" "/tmp")
+ (setenv "XDG_DATA_DIRS" ;for /org/freedesktop/secrets/collection
+ (string-append #$output "/share:"
+ (getenv "XDG_DATA_DIRS")))
+ (apply invoke "dbus-run-session" "--"
+ "meson" "test" "--print-errorlogs" "-t" "0"
+ test-options)))))))
(native-inputs
- `(("gettext" ,gettext-minimal)
- ("glib:bin" ,glib "bin") ; for gdbus-codegen, etc.
- ("gobject-introspection" ,gobject-introspection)
- ("pkg-config" ,pkg-config)
- ("vala" ,vala)
- ("xsltproc" ,libxslt)))
+ (list dbus
+ docbook-xml-4.2
+ docbook-xsl
+ gettext-minimal
+ `(,glib "bin") ;for gdbus-codegen, etc.
+ gobject-introspection
+ libxml2 ;for XML_CATALOG_FILES
+ libxslt
+ pkg-config
+ python
+ python-dbus
+ python-pygobject
+ vala))
(propagated-inputs
- (list glib)) ; required by libsecret-1.pc
+ (list glib)) ;required by libsecret-1.pc
(inputs
- ;; The ‘build’ phase complains about missing docbook-xml-4.2 but adding it
- ;; doesn't seem to affect the build result.
- (list docbook-xsl libgcrypt libxml2)) ; for XML_CATALOG_FILES
+ (list libgcrypt))
(home-page "https://wiki.gnome.org/Projects/Libsecret/")
(synopsis "GObject bindings for \"Secret Service\" API")
(description