summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-08-21 02:17:27 +0000
committerEfraim Flashner <efraim@flashner.co.il>2016-09-05 21:59:38 +0300
commitc2b411c288637d2877aaa2785500fea235f6fd32 (patch)
tree25c4542e77a51e7e3a29de630acca7a2476d48f9 /gnu
parent901c1aae0a58811dc7d4892118a38c8354c294fc (diff)
gnu: Add freealut.
* gnu/packages/audio.scm (freealut): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/audio.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 67701a0f37..9f03368168 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
+;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1511,6 +1512,32 @@ buffers, and audio capture.")
(home-page "http://kcat.strangesoft.net/openal.html")
(license license:lgpl2.0+)))
+(define-public freealut
+ (package
+ (name "freealut")
+ (version "1.1.0")
+ (source (origin
+ (method url-fetch)
+ ;; Upstream url is unclear, many systems use Fedora, there is also
+ ;; https://github.com/vancegroup/freealut though the status of it
+ ;; (official? unofficial?) is not clear.
+ (uri (string-append
+ "https://pkgs.fedoraproject.org/repo/pkgs/" name "/" name "-"
+ version ".tar.gz" "/e089b28a0267faabdb6c079ee173664a/" name
+ "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0kzlil6112x2429nw6mycmif8y6bxr2cwjcvp18vh6s7g63ymlb0"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ; no check target
+ (inputs
+ `(("openal" ,openal)))
+ (synopsis "Free implementation of OpenAL's ALUT standard")
+ (description "freealut is the OpenAL Utility Toolkit.")
+ (home-page "http://kcat.strangesoft.net/openal.html")
+ (license license:lgpl2.0)))
+
(define-public patchage
(package
(name "patchage")