summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-05-23 00:40:01 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-05-23 00:45:44 +0100
commitc3fe248e6987025c7d4ffdb6da0a3fc77f5a3f39 (patch)
tree5b2c062b62dd2a59cc0017b591f4189e73d5aa2f /gnu
parent2234a1f282eb5cbbca1317471f4a1f41a33eeb48 (diff)
gnu: kubo: Unbundle go-github-com-quic-go-quic-go.
* gnu/packages/ipfs.scm (kubo): Unbundle go-github-com-quic-go-quic-go. [inputs]: Remove go-github-com-francoispqt-gojay and go-github-com-gogo-protobuf; add go-github-com-quic-go-quic-go. Change-Id: I4838bfed195b5e094f68ef73333ce9c7c7c7566e
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ipfs.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index e3210a4266..cc645de8d0 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -441,6 +441,7 @@ written in Go.")
"vendor/github.com/prometheus/client_model"
"vendor/github.com/prometheus/common"
"vendor/github.com/prometheus/procfs"
+ "vendor/github.com/quic-go/quic-go"
"vendor/github.com/spaolacci"
"vendor/github.com/stretchr"
"vendor/github.com/syndtr"
@@ -542,6 +543,7 @@ written in Go.")
go-github-com-pbnjay-memory
go-github-com-pkg-errors
go-github-com-prometheus-client-golang
+ go-github-com-quic-go-quic-go
go-github-com-stretchr-testify
go-github-com-syndtr-goleveldb-leveldb
;;go-github-com-tidwall-gjson
@@ -570,10 +572,8 @@ written in Go.")
;; A list of indirect dependencies requiring for the vendored models.
;; XXX: Remove them when all of the vendored packages are available.
;;
- go-github-com-alecthomas-units
- go-github-com-flynn-noise
- go-github-com-francoispqt-gojay
- go-github-com-gogo-protobuf
+ go-github-com-alecthomas-units ; github.com/ipfs/boxo
+ go-github-com-flynn-noise ; github.com/libp2p/go-libp2p
go-github-com-golang-groupcache
go-github-com-gorilla-mux
go-github-com-gorilla-websocket