summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-14 16:15:34 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-15 13:02:53 -0400
commitc61ea717b05e37b8ea80f1cd2f2811459117f60c (patch)
treef95ff541c0a34daab1353d2e98581c1e1550077a /gnu
parentca3fea7636d07d3063b66158a8ca207cff53b0bb (diff)
gnu: Add python-robotframework-pythonlibcore.
* gnu/packages/python-xyz.scm (python-robotframework-pythonlibcore): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2120414b7b..e4ae5844f7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4516,6 +4516,43 @@ for SSH and SFTP. It has the following main usages:
@end itemize")
(license license:asl2.0)))
+(define-public python-robotframework-pythonlibcore
+ (package
+ (name "python-robotframework-pythonlibcore")
+ (version "3.0.0")
+ (source
+ (origin
+ (method git-fetch) ;no tests in pypi archive
+ (uri (git-reference
+ (url "https://github.com/robotframework/PythonLibCore")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0v89v8va65l6inh0fb34qgxawx6p29pnrmw4n5941yzdi3804rc4"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "utest/run.py")))))))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-mockito" ,python-pytest-mockito)
+ ("python-robotframework" ,python-robotframework)))
+ (home-page "https://github.com/robotframework/PythonLibCore")
+ (synopsis "Robot Framework Python library tools")
+ (description "PythonLibCore provides tools for creating larger test
+libraries for Robot Framework using Python. The Robot Framework hybrid and
+dynamic library APIs give more flexibility for library than the static library
+API, but they also set requirements for libraries which need to be implemented
+in the library side. PythonLibCore eases the problem by providing a simpler
+interface and by handling all the requirements towards the Robot Framework
+library APIs.")
+ (license license:asl2.0)))
+
(define-public python-rstr
(package
(name "python-rstr")