summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-17 22:36:30 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-17 22:36:30 +0000
commitccbf143927a0e39c2a4516d6dfdab40ebfa34ef9 (patch)
tree54441a897d3c065d061197708d622b1855d91f76 /gnu
parent18240ae446e313f1f167d5a1b32004edf3f4d04c (diff)
gnu: python-watchdog: Simplify package.
* gnu/packages/python-xyz.scm (python-watchdog) [build-system]: Swap to pyproject-build-system. [arguments] <#:test-flags>: Move skipped test here. <#:phases>: Use standard 'check phase. Change-Id: Id813dcfb567f9769fbb4408a159519004c67b85b
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 2 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 60a1a9a80b..932e0c48c9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29215,17 +29215,9 @@ files. These files are used to translate strings in android apps.")
(uri (pypi-uri "watchdog" version))
(sha256
(base32 "1rx2nyl0cyj0v4ja795cl3gi26577c5wg48syr3byz3ndkgpavm3"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
- (when tests?
- (add-installed-pythonpath inputs outputs)
- (invoke "python" "-m" "pytest" "-k"
- ;; This test failed.
- "not test_kill_auto_restart")))))))
+ (list #:test-flags #~(list "-k" "not test_kill_auto_restart")))
(propagated-inputs
(list python-pathtools python-pyyaml))
(native-inputs