summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:29:28 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:41 +0200
commitcebfc78ae24eaa835e3a5df51e8c9fffdedfef76 (patch)
treef60f1b83c159105bda1adbdea82838cb9002c7f3 /gnu
parent0e2823cc098d4c28d29557e52ca272e164ee6a2e (diff)
gnu: Add texlive-pst-optic.
* gnu/packages/tex.scm (texlive-pst-optic): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a677f22bf7..5a21896fc4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -33630,6 +33630,26 @@ and flexible ways. The components may be connected with fibers or beams, and
realistic raytraced beam paths are also possible.")
(license license:lppl1.3+)))
+(define-public texlive-pst-optic
+ (package
+ (name "texlive-pst-optic")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/pst-optic/"
+ "tex/generic/pst-optic/"
+ "tex/latex/pst-optic/")
+ (base32
+ "1qgxqygcfv3v6wkf6igkyp5aimp9f9nvfyizcwlxlxr32mjvvbly")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/pst-optic")
+ (synopsis "Drawing optics diagrams")
+ (description
+ "This package provides a package for drawing both reflective and
+refractive optics diagrams.")
+ (license license:lppl)))
+
(define-public texlive-pst-text
(package
(name "texlive-pst-text")