summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-01 07:46:54 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-01 07:52:02 +0000
commitd2364f179700b0ab0ccbbaa57d35adaca234fe81 (patch)
treea324b599a69264e4d2a7e43f382165cb3d0374b6 /gnu
parenteff0cdd28f7fc642c769534c2806c7bade205af9 (diff)
gnu: go-structlayout: Fix build.
* gnu/packages/golang-check.scm (go-structlayout) [arguments] <#:go>: Swap to go-1.20. Change-Id: I97721cec7624a89439113cf089599d4229ff1d33
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-check.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 5ab289d961..380ff7e149 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -689,7 +689,8 @@ simplifications, and enforces style rules.")))
(inherit go-honnef-co-go-tools)
(name "go-structlayout")
(arguments
- `(#:import-path "honnef.co/go/tools/cmd/structlayout"
+ `(#:go ,go-1.20
+ #:import-path "honnef.co/go/tools/cmd/structlayout"
#:unpack-path "honnef.co/go/tools"
#:install-source? #f))
(synopsis "Display the layout (field sizes and padding) of structs in Go")