summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-02-04 13:40:17 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-18 12:34:47 +0000
commitd2eb7a2b5a9030e933f18e7211274a201d256de4 (patch)
treeb00410fd6891b145c340b8ec12d7f66e0bea3e70 /gnu
parentded5f62abe6ca8659066516f1dfa8041dc3de04d (diff)
gnu: node-string-decoder: Move package in alphabetical order.
* gnu/packages/node-xyz.scm (node-string-decoder): Move package in alphabetical order. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/node-xyz.scm66
1 files changed, 33 insertions, 33 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 11f3bae3f3..180e4e9f69 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -735,6 +735,39 @@ compatibility check.")
protocol used in @code{node-lynx}.")
(license license:asl2.0)))
+(define-public node-string-decoder
+ (package
+ (name "node-string-decoder")
+ (version "1.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nodejs/string_decoder")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0xxvyya9fl9rlkqwmxzqzbz4rdr3jgw4vf37hff7cgscxkhg266k"))))
+ (build-system node-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'patch-dependencies 'delete-dependencies
+ (lambda args
+ (delete-dependencies
+ '("tap" "core-util-is" "babel-polyfill")))))
+ ;; FIXME: Tests depend on node-tap
+ #:tests? #f))
+ (inputs (list node-safe-buffer node-inherits))
+ (home-page "https://github.com/nodejs/string_decoder")
+ (synopsis "Decode buffers while preserving multi-byte sequences")
+ (description "This package provides a user-land implementation of
+Node-core's @code{string_decoder}, which serves to decode buffers to
+strings so that the decoded string does not contain incomplete multibyte
+sequences.")
+ (license license:expat)))
+
(define-public node-semver
(package
(name "node-semver")
@@ -838,39 +871,6 @@ function with browser support.")
particular cross-platform spellings of the PATH environment variable key.")
(license license:expat)))
-(define-public node-string-decoder
- (package
- (name "node-string-decoder")
- (version "1.3.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/nodejs/string_decoder")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0xxvyya9fl9rlkqwmxzqzbz4rdr3jgw4vf37hff7cgscxkhg266k"))))
- (build-system node-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'patch-dependencies 'delete-dependencies
- (lambda args
- (delete-dependencies
- '("tap" "core-util-is" "babel-polyfill")))))
- ;; FIXME: Tests depend on node-tap
- #:tests? #f))
- (inputs (list node-safe-buffer node-inherits))
- (home-page "https://github.com/nodejs/string_decoder")
- (synopsis "Decode buffers while preserving multi-byte sequences")
- (description "This package provides a user-land implementation of
-Node-core's @code{string_decoder}, which serves to decode buffers to
-strings so that the decoded string does not contain incomplete multibyte
-sequences.")
- (license license:expat)))
-
(define-public node-readable-stream
(package
(name "node-readable-stream")