summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:32:54 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:44 +0200
commitd628311856d1f2690e5ef34d3179e4e15f885ffc (patch)
tree4e806dda45a49c75fb1429ba6e54124087f4eafd /gnu
parentbb3e507c95bdea503f8d8888d2e1b2f183851292 (diff)
gnu: Add texlive-pst-sigsys.
* gnu/packages/tex.scm (texlive-pst-sigsys): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7734d212fb..b8ba137615 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -33948,6 +33948,31 @@ Conus, Ammonite, Codakia, Escalaria, Helcion, Natalina, Planorbis, and
Nautilus, all with different parameters.")
(license license:lppl)))
+(define-public texlive-pst-sigsys
+ (package
+ (name "texlive-pst-sigsys")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/pst-sigsys/"
+ "tex/generic/pst-sigsys/"
+ "tex/latex/pst-sigsys/")
+ (base32
+ "18g1s1afh3lnkb3993k1ypkzbb4a88jw5paclwgyn59yqjq8x737")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/pst-sigsys")
+ (synopsis "Support of signal processing-related disciplines")
+ (description
+ "The package offers a collection of useful macros for disciplines related
+to signal processing. It defines macros for plotting a sequence of numbers,
+drawing the pole-zero diagram of a system, shading the region of convergence,
+creating an adder or a multiplier node, placing a framed node at a given
+coordinate, creating an up-sampler or a down-sampler node, drawing the block
+diagram of a system, drawing adaptive systems, sequentially connecting a list
+of nodes, and connecting a list of nodes using any node-connecting macro.")
+ (license license:lppl)))
+
(define-public texlive-pst-text
(package
(name "texlive-pst-text")