summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorFabio Natali <me@fabionatali.com>2023-10-07 10:54:02 +0100
committerChristopher Baines <mail@cbaines.net>2023-10-11 12:11:40 +0100
commitd6afcffb217ade8573fb86ef18d6740d1a9cba4d (patch)
tree361f973d5efd917efd24fef38f1fc91e231db3f9 /gnu
parent378dfcf306cd1f5e38f973f7bc8fa0a018c7c81a (diff)
gnu: emacs-mastodon: Update to 1.0.6.
* gnu/packages/emacs-xyz.scm (emacs-mastodon): Update to 1.0.6. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm63
1 files changed, 30 insertions, 33 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 925f04aab9..7370d9539c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -32828,40 +32828,37 @@ time.")
(license license:gpl3+)))
(define-public emacs-mastodon
- ;; No release in ~1 year, hence this snapshot.
- (let ((commit "20dec8871c9bb5f5e418bfc197e7533b5e3065e3")
- (revision "1"))
- (package
- (name "emacs-mastodon")
- (version (git-version "1.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://codeberg.org/martianh/mastodon.el")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "15cfjny99yw5frdp8nlyazlwgscvfvbinsj0fbdfprxf50k2zjs6"))))
- (build-system emacs-build-system)
- (arguments
- (list #:phases
- #~(modify-phases %standard-phases
- ;; Move the source files to the top level, which is included in
- ;; the EMACSLOADPATH.
- (add-after 'unpack 'move-source-files
- (lambda _
- (let ((el-files (find-files "./lisp" ".*\\.el$")))
- (for-each (lambda (f)
- (rename-file f (basename f)))
- el-files)))))))
- (propagated-inputs
- (list emacs-request emacs-ts emacs-persist))
- (home-page "https://codeberg.org/martianh/mastodon.el")
- (synopsis "Emacs client for Mastodon")
- (description "@code{mastodon.el} is an Emacs client for Mastodon, the
+ (package
+ (name "emacs-mastodon")
+ (version "1.0.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://codeberg.org/martianh/mastodon.el")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1z5lmzxhindxa0f6qi6z361k9smqcz68alr6w6jbmwg279qmk8jj"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ ;; Move the source files to the top level, which is
+ ;; included in the EMACSLOADPATH.
+ (add-after 'unpack 'move-source-files
+ (lambda _
+ (let ((el-files (find-files "./lisp" ".*\\.el$")))
+ (for-each (lambda (f)
+ (rename-file f
+ (basename f)))
+ el-files)))))))
+ (propagated-inputs (list emacs-request emacs-ts emacs-persist))
+ (home-page "https://codeberg.org/martianh/mastodon.el")
+ (synopsis "Emacs client for Mastodon")
+ (description "@code{mastodon.el} is an Emacs client for Mastodon, the
federated microblogging social network.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-ebdb
(package