summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-08-30 22:42:29 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-08-30 22:42:50 +0200
commitd85c0f98424444eee10c721a03b400498cc89a6a (patch)
treeca7af7e9f091feee764e607366b191ecd97bc18f /gnu
parent06947252d3de55aff765334b88cde5990efa6abf (diff)
gnu: Add r-genie3.
* gnu/packages/bioconductor.scm (r-genie3): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index ea43bf2fdf..b7bc58d507 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -5230,3 +5230,24 @@ cis-regulatory topics (cisTopics) from single cell epigenomics data, and
includes functionalities to identify cell states based on the contribution of
cisTopics and explore the nature and regulatory proteins driving them.")
(license license:gpl3))))
+
+(define-public r-genie3
+ (package
+ (name "r-genie3")
+ (version "1.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "GENIE3" version))
+ (sha256
+ (base32
+ "0lvrpw4xn7xyinmn13f65i0vkzfzwdj5y8gsa8vyy8kcn83d28fx"))))
+ (properties `((upstream-name . "GENIE3")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-reshape2" ,r-reshape2)))
+ (home-page "https://bioconductor.org/packages/GENIE3")
+ (synopsis "Gene network inference with ensemble of trees")
+ (description
+ "This package implements the GENIE3 algorithm for inferring gene
+regulatory networks from expression data.")
+ (license license:gpl2+)))