summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-07-27 00:15:43 +0100
committerAndreas Enge <andreas@enge.fr>2023-08-08 09:36:59 +0200
commitd8ef4eef3db26f22391f6114b397de4dc91c8b7d (patch)
tree065b92dc8afaed2979137dd31fed1aaa84260675 /gnu
parent98c17c14829349d4838186400541a7cd650b64d0 (diff)
gnu: python-reproject: Update to 0.11.0.
* gnu/packages/astronomy.scm (python-reproject): Update to 0.11.0. [native-inputs]: Move python-pyvo, python-gwcs, python-shapely from here ... [propagated-inputs]: ... to here. Add python-click, python-cloudpickle, python-dask, python-fsspec, python-zarr. Signed-off-by: Andreas Enge <andreas@enge.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm25
1 files changed, 15 insertions, 10 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 67ae8cf572..a22d2706f4 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2141,13 +2141,13 @@ Virtual observatory (VO) using Python.")
(define-public python-reproject
(package
(name "python-reproject")
- (version "0.10.0")
+ (version "0.11.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "reproject" version))
(sha256
- (base32 "1ha0a1ja7k09ysd05adffgsapfwzc6m6az34a0av2mhmlwy4zb1q"))))
+ (base32 "0p07qlqinb826m4n5b5invyfyv4z750sai2caqaf598mgj04l61p"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -2170,21 +2170,26 @@ Virtual observatory (VO) using Python.")
(lambda _
(setenv "HOME" (getcwd)))))))
(propagated-inputs
- (list python-astropy
+ (list python-asdf
+ python-astropy
python-astropy-healpix
+ python-click
+ python-cloudpickle
+ python-dask
+ python-fsspec
+ python-gwcs
python-numpy
- python-scipy))
+ python-pyvo
+ python-scipy
+ python-shapely
+ python-zarr))
(native-inputs
- (list python-asdf
- python-cython
+ (list python-cython
python-extension-helpers
- python-gwcs
python-pytest-astropy
- python-pyvo
python-semantic-version
python-pytest
- python-setuptools-scm
- python-shapely))
+ python-setuptools-scm))
(home-page "https://reproject.readthedocs.io")
(synopsis "Astronomical image reprojection in Python")
(description